SEO Toolkit Endless Analyzing Bug

I came across this bug for the second time now and decided to post the resolution so that it may help other developers save some time before turning to Sitecore Support.

Bug:

After installing the SEO Toolkit module when you click on the Search Engine Optimization button in the Desktop, a new window opens up and starts loading the home page.  However, when analyzing that page, or any other for that matter, the “Analyzing page…” continues to spin in the upper right hand corner and never returns any data in the tabs in the very bottom of the web page.

I encountered this bug in these versions:

  • Sitecore Version: 6.6.0 rev. 130111 using SEO Toolkit Version: 1.3.0 rev. 120613
  • Sitecore Version: 6.5.0 rev. 120706 using SEO Toolkit Version: 1.3.0 rev. 110530

Resolution:

  1. Save the image below to your local hard drive (“delete.png”) file and place it in the “\Website\seotoolkit” folder.
    delete.png
  2. Modify the “Website\seotoolkit\client\link.js” file:
Replace this line:
overlay.innerHTML = '<img src="' + seo.page.baseUrl + linkDeleteImageUrl + '" />';
With this one:
overlay.innerHTML = '<img src="' + seo.page.baseUrl + "/seotoolkit/delete.png" + '" />';

This should fix the issue and any page you go to should now take a little bit of time to analyze the page and render data at the bottom of the web page.  Happy coding!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s